Monero deposits/withdrawals will take a long time be processed
Incident Report for MorphToken
Resolved
Monero block times are significantly better now, for the moment we're lifting this warning.
Posted Apr 07, 2018 - 15:24 EDT
Monitoring
The recent Monero software update (hardfork to v7) caused a significant drop in the mining hashrate and blocks are being mined much slowly. While that's going on, MorphToken will take much longer to process both deposits and withdrawals.
Posted Apr 06, 2018 - 13:19 EDT