Website is partially down
Incident Report for MorphToken
Resolved
This incident has been resolved.
Posted Oct 26, 2018 - 12:41 EDT
Update
Website is available everywhere again but performance is still degraded.
Posted Oct 26, 2018 - 12:36 EDT
Investigating
We are currently investigating this issue.

Europe and Asia unaffected, a third party CDN is offline in other regions.
Posted Oct 26, 2018 - 12:22 EDT