Trades are not being executed
Incident Report for MorphToken
Resolved
This incident has been resolved.
Posted Jun 05, 2018 - 11:05 EDT
Monitoring
A third party is out of service, we're monitoring the situation.
Posted Jun 05, 2018 - 10:21 EDT
This incident affected: Internal services.